SureTrend 2

Why is SureTrend showing me an error that says “The model type is different…” ?

Newer models of EnSURE or SystemSURE Plus (with a V2 next to the serial number) are not compatible with SureTrend versions 2.03 or earlier. The expanded storage capacity of V2 luminometer models prevents earlier versions of SureTrend from syncing correctly with the luminometer. All you have to do is upgrade your version of SureTrend! Follow this easy step by step guide: Upgrading to SureTrend Version 3.01 . Please feel free to contact Hygiena technical support for assistance.